After many years of packaging work by many contributors, today I was able to install native debian package.

Out of 101 direct dependencies and 223 total dependencies, only 7 of them needed to be handled outside of debian packages.

autprefixer-rails gem had to be installed from rubygems.org because debian does not have browserify packaged and building with rollup and webpack created a broken bundle.

-diaspora -packaging (1/2)

Follow

6 gems had to be vendored because diaspora is still using sass-rails which is dead upstream and debian already moved to sassc-rails.

If you'd like to help test it, follow wiki.debian.org/Diaspora#Buste

I still need to integrate systemd unit files to handle starting and stopping of the services automatically.

-diaspora -packaging (2/2)

Sign in to participate in the conversation
Mastodon

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!