Any developers interested in taking up this challenge?

Build 1.x with 7.x

Yarn 2.x already moved to babel 7.x but there is no stable release for yarn 2.x and it is completely different from yarn 1.x.

This will help us ship yarn in (we already moved everything else to babel 7.x but could not port this yet) for next stable release bullseye.

It would be useful to nodejs developers to make initial installation of yarn easy.

The situation seems worse than I initially thought.

As per yarn 2 announcement blog,

dev.to/arcanis/introducing-yar

Yarn 2 can be installed using yarn 1 only!

Why do everyone has reinvent a different wheel?

@nodejs

@paolog tried packaging yarn 2 and this is what he found

bugs.debian.org/cgi-bin/bugrep

Quoting part of it,

"the tarball is 180 MB (up from ~70 MB for yarn 1) and has all dependencies needed to run yarn (!) including monaco-editor (?) from Microsoft (the code editor which powers VS Code), react-icons, 6 versions of the typescript tree (version 3.75, 3.95 and 4.1 and three patched versions) etc."

Follow

@paolog

So now installing yarn 2 on is like,

# apt install npm
# npm install -g yarn
$ yarn set version berry

@praveen yes but the last line only applies locally in a project

Sign in to participate in the conversation
Mastodon

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!